You need flash 8 or newer